¿Deberías actualizar a WordPress 5.0 el 6 de diciembre?

Por en

WordPress 5.0 saldrá al fin este 6 de diciembre, y la incertidumbre ronda en muchos sobre si deben o no actualizar a WordPress 5.0 o quedarse en la rama actual; para muchos es una fecha desafortunada, para otros es un anuncio dado con extremada premura, y sobra decir que no ha sido bien recibido, en particular por las casas de plugins más importantes que hay en la comunidad de WordPress. Y al final los que pagarán los platos rotos son los usuarios comunes y corrientes, los que no están al tanto del día a día tras bambalinas de WordPress, que no están en GitHub, no están en Slack ni en ningún otro canal, y que ciertamente no tienen porqué estar, y que resultan confundidos de todo lo que se dice en redes sociales y posts de blogs, algunos a favor y otros en contra.

Como todos saben, la novedad en WordPress 5.0 es el nuevo editor de contenido Gutenberg, el cual será el editor por default; puedes brincártelo instalando el plugin Classic Editor, y tendrás soporte hasta el 2022, y después ya veremos que pasa. Pero mientras, muchos posiblemente actualicen y no sabrán que los golpeó cuando vean que sus plugins y tema no funcionan bien, o al menos no como ellos recordaban. Tan importante es Gutenberg en esta actualización de WordPress 5.0, que podemos considerar que WordPress 5.0 es 85% Gutenberg. El resto es peccata minuta.

Actualizar a WordPress 5.0, ¿si o no?

Así que, al grano: ¿deberías actualizar a WordPress 5.0 el 6 de diciembre cuando salga? la respuesta tajante es un rotundo NO. Permítanme ser claro: yo soy pro-Gutenberg, lo vengo usando desde versiones pre-2.0 y al día de hoy me parece genial – una vez que aprendes a usarlo (si aún no lo sabes usar, es hora de aprender Gutenberg con mi tutorial), pero la realidad del asunto es que no está listo para todos los casos de uso que podrían haber.

Está el problema de la usabilidad, que aunque ha mejorado, todavía sigue con problemas significativos, e incluso causó problemas internos en el equipo encargado de este tema. Tenemos también problemas recurrentes, como el copiado y pegado que en una versión funciona, a la otra no, y así ha estado por varias iteraciones. Hoy en día al parecer hay un problema pegando desde texto de Word. Hay plugins que no funcionan bien…y eso sólo por mencionar algunos problemas muy evidentes.

Por otro lado tenemos a personajes importantes en la industria, de varias empresas significativas, levantando la mano y diciendo que Gutenberg no está listo:

Estas son apenas unas muestras de que muchos no están de acuerdo con la fecha de lanzamiento ni con el estado actual de WordPress 5.0.

Hay que leer los comentarios del post donde Matt Mullenweg anuncia la fecha del 6 de diciembre, donde se aprecia claramente que le pegan con todo a Matt desde todas las direcciones, en particular donde buscan motivos de porqué está persiguiendo esta fecha de liberación tan agresivamente, y las teorías parecen apuntar a que quieren que esté listo para dar su presentación anual llamada “State of the Word” durante el WordCamp US que se llevará a cabo del 7 al 9 de diciembre en Nashville, y en donde reflexiona sobre todo lo que sucedió en WordPress durante el año y lo que viene para el próximo.

Y no olvidemos que hay un componente humano en toda esta debacle; los programadores del Core deben estar totalmente fundidos luego del esfuerzo sobrehumano al que han sido sometidos por esta calenderización agresiva – que hay que decirlo, viene únicamente de Matt Mullenweg, el cabecilla de WordPress (proyecto comunitario, mis polainas).

Y también está todo el personal voluntario que tendrá que soportar toneladas de mensajes de soporte en los foros tanto de wordpress.org como de plugins premium; no luce nada bien para ellos.

Sugerencias para la salida de WordPress 5.0

Mis sugerencias para este lanzamiento de WordPress 5.0 son las siguientes:

Ahora es buen momento de generar un respaldo COMPLETO de tu sitio, archivos y base de datos. Este será tu último respaldo confiable antes de cualquier movimiento que hagas relacionado con WordPress 5.0.

Escenario #1: NO quiero actualizar a WordPress 5.0 y NO quiero Gutenberg

  • Deberás actualizarte sólo a WordPress 4.9.9, que es la versión actualizada de la rama actual
  • Aunque no haga mucha falta en este escenario, instala el plugin Disable Gutenberg por cualquier cosa,  el cual te da control completo para desactivar Gutenberg, así como ocultar los avisos de que lo instales

Escenario #2: quiero actualizar a WordPress 5.0 pero NO quiero Gutenberg

  • Antes de actualizar, prueba tu instalación actual con WordPress 5.0, ya sea que tengas la funcionalidad de staging en tu servidor, o bien crear un entorno de pruebas local para poder probar WordPress 5.0 y todo lo que usas en tu sitio actual, es decir, temas y plugins
  • En el tema particular del plugin WooCommerce, tendrás que tenerlo actualizado a la versión 3.5.1 o superior para evitar problemas
  • Cuando hayas probado que todo funciona en tu entorno local o en tu staging en tu hosting, actualiza a WordPress 5.0
  • Instala el plugin Disable Gutenberg, el cual te da control completo para deshabilitar Gutenberg
    • La configuración recomendada es habilitar la opción “Complete Disable”, con esto Gutenberg queda deshabilitado por completo

Escenario #3: quiero actualizar a WordPress 5.0, pero con acceso dual al editor clásico y Gutenberg

  • Antes de actualizar, prueba tu instalación actual con WordPress 5.0, ya sea que tengas la funcionalidad de staging en tu servidor, o bien crear un entorno de pruebas local para poder probar WordPress 5.0 y todo lo que usas en tu sitio actual, es decir, temas y plugins
  • En el tema particular del plugin WooCommerce, tendrás que tenerlo actualizado a la versión 3.5.1 o superior para evitar problemas
  • Cuando hayas probado que todo funciona en tu entorno local o en tu staging en tu hosting, actualiza a WordPress 5.0
  • Instala el plugin Disable Gutenberg, el cual te da control completo para deshabilitar Gutenberg
    • La configuración recomendada es deshabilitar la opción “Complete Disable”, y ajustar para que roles quieres que se muestre Gutenberg
    • Verás enlaces nuevos en Entradas; uno de ellos es “Añadir nueva (Classic)” y bajo cada entrada verás un enlace “Edit (Classic)“, si usas estos verás el editor clásico

Escenario #4: demasiado tarde, ya actualicé a WordPress 5.0, ¿cómo regreso a una versión anterior?

  • Calma, “que no panda el cúnico“; instala el plugin WP Downgrade y echa para atrás tu WordPress.

Escenario #5: soy temerario, ¡quiero actualizar a WordPress 5.0 ya!

  • ¡Adelante, vaquero! ¡actualiza ahora mismo sin miramientos! (sarcasmo aparte, no lo recomiendo ni un poquito)

Consideraciones generales

  • Seguir los foros de wordpress.org para determinar cuando el “ruido” de todos los problemas haya bajado
  • Esperar a una versión más estable, idealmente en enero tendremos una versión más estable de WordPress

Personalmente creo que Gutenberg es fantástico y creo firmemente que es el futuro de WordPress, pero también hay que ser honesto y decir que no está listo para todos.

Orlando es un ingeniero en sistemas de 43 años de edad, apasionado del desarrollo de software y con un cariño especial por WordPress. Le encantan los libros, la música, la fotografía, los cómics y es un AFOL. De último pero no menos, esposo y padre de dos trolls.

Deja un comentario

Centro de preferencias de privacidad

      Necessary

      Advertising

      Analytics

      Other

      A %d blogueros les gusta esto: